Panzer Elite: Object Editor











Introduction


The Object Editor provides the necessary tools to convert and edit all 3D objects for Panzer Elite. This tool allows you to assign textures, materials, and attributes to imported 3d Studio mesh files. What does this mean?


This is the tool we used to edit and implement all objects you see in the game. This includes plants, trees, houses, tanks and all other vehicles. This tool does NOT create 3d models for new objects. For this you need a 3d modeler program which exports 3DS file format. Examples would be Lightwave, 3D Studio or 3D Studio Max. 





In Quake words: This tool allows you to create MODS for Panzer Elite.





First, the usual warning: you can seriously mess up your installation with this tool. Make backup copies of all files you modify.





This Document is....


This docuemt isnt finished yet. It will be continuesly updated through the website. It was a decision of either delaying the tool to be published or this incomplete manual. I hope you understand.





Objects are not equal to Objects


Before we begin the tutorial I need to explain some basics how Panzer Elite differentiates objects. There are three main types of objects in the game: trees (or pole objects, anything which falls over when being hit), houses (any structure collapsing when being hit) and finally vehicles (any moveble object).


Each of those three got their distinct way of editing and attributes. Attributes are values or markers the game needs to find certain information about the object. An example would be that the game needs to now where the wheels of a tank are to make the suspension animation. I will include a section for each object type below with the individual information.





Textures


Panzer Elite has its own unique way storing and using textures. The reason for this is historical: the game was started when 3d accelerator cards werent even anounced, so we started using a software renderer which had all sorts of restrictions on it to improve performance to display the detail we need for a proper tank sim.


Thus we use 7 texture libraries, thats 7 images with textures pasted side by side to be assigned to objects. The 7 libraries are assigned and numbered for the following types of objects:





Texture library 1: For german vehicles


Texture library 2: For allied vehicles


Texture library 3: For plants and trees


Texture library 4: For infantry


Texture library 5: For buildings


Texture library 6: For buildings too


Texture library 7: For the interior of the player tank





Its important to load the texture libraries into the specific slot and not to change this order as otherwise the current objects wouldnt find their assigned textures and crash the game. See tutorial how to load those libraries. Note: you only need to load the texture libraries which the object needs, you do NOT need to load all of them all the time.





Texture libraries come in three (3) sets: one for the desert, one for the Sicily/Italy campaign, and one for the Normandy Campaign. This allows different camouflage for the tanks, different style of houses and plants being used. There will be a 4th soon for the winter battles (Mission Disk).





Tutorial: Tree


Lets start easy, step by step:





The 3 Objects Editor Windows


When you start the editor three windows open up: The top one contains the main menu and buttons. The large left one will contain the 3D view of your object while the right tall one will contain the textures. Its important to realize that the texture window has its own menu as well. to make references easier we will refer to the three windows as follows:





MB: Main Menu and Buttons refers to the top window


3D: Refers to the 3d view


TLB: refers to the Texture library window





Loading a Texture Library


First choose the library NUMBER in the TLB to switch to the texture library you want to load: Click on the "3" in the TLB. Use the "File" menu of the TLB with the command "Load...". Direct the "Open file dialog" to your Panzer Elite installation folder, in there switch to the texture folder. Click on Desert3.tlb and "Open" to load this library. After a short loading time some textures for trees should appear in the TLB.


If you like you can look at all textures by loading them into the appropriate slot as explained above in section "Textures".





Loading an Object


Now use the "File" menu in the MB, "Load Object...". Navigate the open file dialog to the folder "Desert_Obj". In there load "aaCactus1". A cactus should appear in your 3D window.





Viewing an Object in 3D


Right click and hold your mouse button and move the mouse to rotate the Cactus. The object rotates around two axis, if you want to rotate around the other axis hold down the Ctrl-key as well. Holding down the shift key while moving with the right mouse button moves the object left/right and up/down in the 3D. Holding down the shift AND control key while doing the right click and hold method moves your camera TO or AWAY from the object. Careful: sometimes when you moved the object too far its difficult to find it again. 





Assigning Textures


First we must learn how to select faces of our 3d object. Click with the mouse on any part of the Cactus in the 3D window. Notice how a face has a red outline now, this means its selected. You can select as many faces as you want. If you want to unselect just press space.


Now select a texture in your TLB. To do this simply click on any image you see in the TLB. Selected textures get an outline to show that is has been selected.


Now activate the 3D window again (simply click on the title bar of the window). Note that the selected faces are still selected. Now press the button in the MB with the brush in it � to assign the texture. See how the face changed to the texture you selected? Now you might not see it correctly, the reason is how Panzer Elite limits textures to a face (see below).








Naming Conventions


Objects must be named in a specific wy to be compatible with Panzer Elite. Objects must only be renamed with the Object Editor, otherwise they wont function.





Vehicles: names with no spaces or special characters. The names refer to the DATANAME in the unitdata. If you want to replace a vehicle use the identical name.


Houses: trees and buildings must be named with an "aa" in front. This letter code describes the destruction level of an object. Example. "aahouse1" is the undamaged house, while "abhouse1" is the next destriction level, "achouse1" the third and finally "adhouse1" the last usually.


Trees/Masts: Those are named identical to the house naming convention. They only have two desctrution levels though, "aa" and "ab", because they fall over.


If you save an object to replace an existing one use the identical name please. Upper/Lower case doesnt matter.





Texture Limits


Textures in Panzer Elite only fit into rectangles. Triangles cannot be textured other than with a 16x16 pixel texture. In other words if you want to change a tanks texture to something with a national symbol in it for example better choose a side where there is a rectangle. Rectangles are the only faces in Panzer Elite who can show textures larger than 16x16. Because 99% of all faces are rectangles anyway this usually doesnt matter, but its important to know.


Textures can be divided into smaller subparts to be assigned to a face. As an example you can use a 64x64 pixel camouflage and only use parts of it. There are limitations though. You can only "cut" a texture to chunks as wide as the original, but the height can be limited to any multiple of 16. The above example of an 64x64 texture can so be divided into 64x16, 64x32, and 64x48. We offered this possibility to save texture space.


Texture sizes are limited to multitudes of 16 in height and width, ie a texture MUST be 16, 32, 48, 64 etc. pixels wide  or high.





Advanced Tutorial: Vehicles


Lets imagine the 3ds modell of a tank is ready and you want to import that and edit it to be included in the game. To see how our modells looked like we included a folder 3ds (now inside your Panzer Elite installation folder) with  amix of 3ds modells to play with.





Preparation


Click on "1" in the TLB and use the menu in the TLB window to load the texture "Normandy1.tlb". The Normandy textures for the German units should appear. Now use the MB menu "Import 3DS Object" and load the "tiger2-p.3ds" from the supplied 3ds folder inside the Panzer Elite installation. Make sure your import settings are as the default: Quadoptimize is ON, the slider is to its far right (maximum), Wireobject is OFF, Scale 1:1000 is ON. Click on the topmost name (rumpf, the main object all others are linked to like the turret, cannon etc), then click ok. 


The various dialogue boxes now coming up are for debugging only, so click ok on all of them.





First Impressions


Now the Tiger II with the Porsche Turret should appear in your 3d window, but it looks odd. The reason is that no textures are applied, so the editor applies a default checkerboard texture. Second some faces are onesided only, ie. you wont see the wheels from all sides, because the face is only visible from one. We are going to change that soon. Now use the MB window and choose wireframe. Now you get a better view how the vehicle is modelled. 


Sometimes it is necessary to correct the modell because either the importer did somethign wrong or the modeller forgot to weld surfaces or simplify some parts of the modell. For this task we offer 3 buttons. They are:


Split Quad � : This button lets you split a rectangle into two. Just click on a face (red outline appears) and hit this button. See? Its split. Useful for editing or if you joined two fces by accident.


Join Faces � : If you select TWO faces you can join them to one rectangle. Note however that this deletes 2 vertices (the ones who they shared before joining), so any faces connecting to those might be messed up. Experiment. You can also join a rectangle and  triangle. For this to happen you need to select the triangle and the rectangle, then switch to the MB menu "Edit->Select Vertex" and select the vertex which will be deleted to create the new face. You can also join two triangles into one rectangle, the main purpose of this button.


Split into grid � : This function lets you split a rectangle into multiple smaller ones. Lets say you have a large rectangle (like the top of your tanks hull) and you want to split that to assign textures better. What you need to do is to apply a texture to the rectangle which has the size of your grid you want to achieve in 16x16 pixel sizes. Confused? Its easy once you saw it happen. Example: if you assign a 32x32 texture to a face and then use the split quad button the face will be split into 2x2=4 rectangles.





First Work


ok, lets use our new knowledge to edit the Tiger II. Do you noticed that the top of the hull and the front armor plates are split into triangles, and arent nice rectangles?


�


See the above image: I selected examples of wrong faces. Lets start at the frotn armor plates. Deselect any faces by hitting the space key. Now select the two lower hull front armor plate faces and hit the join quad button "-". Do the same with the upper face. Your front should now look like this:


�





You can proceed with any fces you find to join them. A good guideline is always to join faces to rectangles wherever an original armor plate was. Do NOT join the left and right front sides of the turret, those are triangles on purpose to show the rounded turret front :o)





First Texturing


Before we explain mesh editing further lets apply some textures to see what their limits are. For this change back to the "Window->Normal" mode to show the vehicle with textures (currently checkerboard because we havent assigned any). Lets select the two joined armor fronts we did. Click on both so that they are outlined red. Remember you can deselect easily by hitting space. Now click on the first long rectangle camouflage texture in the top left corner of your TLB. Now we selected the faces to be textured and the texture we want to apply. Now hit the texture button � or simply shift-T.


Our Tiger should look now somethign like this:


�





Not bad for the first day. lots of work to do as you can see. Now oftentimes textures dont apply to the face in the direction we want. What can we do? We can rotate the texture! Try it: select one of the textured faces and hit the rotate texture left or right button �. 


If you rotated the textures correctly it looks better now:





�





Materials


The next step understanding textures is to understand materials. Its basically the way the program handles texures. We have predefined the most common ones and will use two of them now.


Turn your Tiger to the side so you can see the place where the wheels should be. Remember? I told you before you can't see them because they are only pointing to one side. We are going to change that now. Select blindly some wheel rectangles (they are square, we are going to change that soon). Your selection should look like this.





�





Now the magic: In the middle pull down menu of the MB select "masked two sided". Then hit the "Assign Material button" besides it: �





Now you see the wheels from all sides. Try it by rotating the tank with your right mouse button. We assigned a material with 2 options. Its two sided: This means that one face shows independend on the direction the user looks on it. IMPORTANT: do not overdo this as the polygons are always rendered, even if they are usually not visible. This costs performance. ONLY use the "2.sided" on faces where they are identical to both sides and actually visible. Good exmples are tracks, wheels etc.


The other attribute we assigned is masked: This means that the texture is handled with one transparent color: the first color is ignored and rendered transparent. Lets check if thats true: select your wheels again, select the large steel wheel in the TLB and hit shift-T.


�


Now you see the effect: wheels, visible from all sides, and round! The color white is ignored. You can test this by assigning the wheel to another face with no material and the white border will show up..


Materials can be defined in the "Define Material" menu. It will be explained in detail shortly.





Attributes


For a tank to function fully the game needs a lot of data to be assigned to the tank. The units performance data is in its unitdata, but things like suspension points, MG's and gun's muzzles must be defined in the Editor so that the game knows where to fins them. lets hit those points in order:





Identify Wheels and Tracks


The most complex step first. You need to defined vertex points on which the tank "rides". A minimum of 4 are needed (one for each corner), but tanks usually have more wheels. In order to do so most modells are created so that a trackink is below each wheel. Lets look at the following picture:


�


This is a magnified view of the tracks and wheels. The red point should be our main suspension point. This one rides on the surface and follows bumps etc. The blue vertexes should FOLLOW the red, as this defines the wheel on top and the other track link. Imagine pulling on all marked vertexes above: you could animate this to be a suspension, this is exactly how it works. But there is more. In order to identify those they need to be numbered too. For this we use the "Assign-> Attribute" or Shift-A. Use "Edit->Select Vertex" to select those. Make sure you select the right ones by rotating the object, otherwise its possible to mark a vertex on the other side.


In the dialogue which appears you need to choose the attribute TYPE first (pull down menu in the dialogue). We MUST use "KettenV" for the suspension point (red), and "RadV" for the blue wheel and tracklink points. The position and level parameters are our numbering fields. Use the position for numbers 0-15. This is sufficient for 16 wheels. Some tanks have more so use psotion "1" and level "1" for the last set, numbering "1,1" to "15,1" as well if neccessary.


Note: the fields are lmited to numbers 0 to 15. Do NOT use numbers greater than 15 in any of those fields. Ignore the top most pull down menu "attribut". You can assign names to certain settings, but we never used those.


So to complete the tracks of ONE side you need to :


�


As shown in this picture you need to number all vertexes marked with numbers to "KettenV" 0 to 8. Mark the appropriate wheels and the other tracklink with the number to which assigned "KettenV" they belong. do not forget to mark those with "RadV".


Repeat that for the other side, but remember to use other numbers too: use 9-15, then 1,1 then 2,1 etc.





Where does the shots comes from?


In order to tell the game where the muzzle of  gun is you need to select a vertex where the shot and particle animation originates from.


Use Edit->select vertex and wireframe mode to select one vertex of the cannon where the shot comes from (on the muzzles front) and assign the attribute "muzzle" to it. Apply the same to the smoke mortar if existing or the 6 smoke dischargers. Apply "mortar" for smokemortars/Nahverteidigungswaffe or "smoke1-6" for smokepods accordingly. Use MG1 for the bow machine gun muzzle, MG2 for the coax, and MG3 for the AAMG.





Where is what?


The game also needs to know where certain parts are from the tank. Use the menu "Assign->Object Attribute". In here you can choose a part of the 3ds mesh file to your left, and assign an attribute to the right. In order to see the right names use "Assign->Get Group from object". This gets the names the artist assigned to the various parts of the tank.





Now lets see what we need to define for a tank:


Rumpf/Tiger2:	Use attribute tank. This defines it as a tank compared to a house or tree.


Turm: 		Assign Turret attribute o the object which is the turret of course.


Raeder/Track: 	Ignore those for now


Bow MG: 	Use attribute MG1. This defines the little bow MG graphics


Commander: 	Use Comsprite attribute. This defines the place the commander will be shown if unbuttoned. (This is for future expansion.)


Hatch: 		Defines the hatch position, ignore for now.


Main Gun: 	Kannone. Defines the main cannon which then can be moved with the keys.


AA_MG3: 	Use MG3 attribute


Coax MG: 	Use MG2. Note: oftentimes the coax isnt its own object, ignore this then.





Final Attributes


Now we need to assign some misc attributes. Mark two vertices on the back of the tank, one on each track. Press shift-A and assign the "DustH" attribute using paramters 4 and 0. This will enable dust particles being emitted there when the tank drivers forward. To emit particles when the tank drives backwards use the DustVattribute.


Now select a vertex (unselect first) on the left side of the coupula where the commander should "look" out of. Mark that with the attribute "Commander". This is essential as the game looks for this vertex when you look out of your tank: it defines the position of the camera. For fun you can try deleting this attribute on an existing tank (set it to house, 0,0) and move the attribute to the drivers position, or to the tip of your cannon.





Testing


You could now test the vehicle if you assigned textures to all surfaces. For testing you could select all faves (Ctrl-A) and assign a dummy teyture. Save the tank over an existing one using the same name and your tank should appear (try instant action). Youc an experiment, even funny tanks could be built.





Advanced Tutorial: Customize Textures


If you want to modify existing textures its pretty easy to load the texture BMP file into any paint program. But how about adding textures?





Panzer Elites Texture structure


PE uses two files: the TLB file (exmaple: Normandy1.tlb) and the BMP file (example: Normandy_8.bmp). The TLB contains the data and sections (the rectangles), while the BMP file holds the graphics in an 8 bit (256 colors) windows compatible _8.BMP file. Why 8 bit? To save space and memory.


This means if you want to add textures you need to make sure they either fit into the palette of the existing one or to convert the picture down to 256 colors from true color yourself. But dont worry, the editor can do that too although Photoshop usually generates better results. 


When you save a texture library first time you will notice it created another file: a _24.bmp. This is your 24 bit picture where you can MODIFY textures. After you are done reduce the picture back to 256 colors. One important thing though: if you do so make sure the transparent color (in most cases white) is color number zero! To test edit the palette (most programs let you do this) and change the first color to pink. If the white background doesnt change to pink now you did it wrong :oP





Adding new Textures


In order to add new textures you need to save your new textures you created with your paint program as a 24bit BMP file INTO THE TEXTURE folder of Panzer Elite (!). Remember that texture sizes are limited to multitudes of 16. 


On the TLB window you see one button � 


Click that (or use the menu "Load Image") and open your 24bit file. Your picture will open in a separate window. Here you can mark rectangular areas with widths and heights in 16 pixel sizes or steps. There is a grid function as well to support copy/pasting multiple textures.


To add a new texture simply resize the area to your texture size, move it over your texture, press Ctrl-C to copy (or use menu), then click into your TLB window and press Ctrl-V (for paste, or use Paste in the menu). This adds your texture. Note: The texture might not appear at the end of the library but whereever the program finds a space for it.  That can be irritating when pasting small 16x16 textures which can end up anywhere in the library.





Finishing up


Now I need to explain that you pasted the textures into the 24 bit picture only. The primary reason is that pasting together images with different colors into a 24 bit picture preserves the colors and thus increases quality when reducing them down to 256 colors. So remember: Do your main work on the 24bit picture and convert that one down to 256 colors. Keep the 24bit picture, thats your high quality reference! In order to convert the 24bit into your 256 color picture within the editor just save the library. This converts the 24bit into the 256 colors and will make sure you can now assign and use the texture you added. When you want to produce better results with color conversion just exit the editor, load the 24 bit version of the library you modified and redice it there, saving as the 8 bit version (with the extension _8.bmp).





Making the process effective


To make the process of adding textures effective you should create your textures so that they fit into a 16x16 pixel grid. This makes copy/pasting them much easier when you align the grid in the copy window of the TLB. To align the grid move a 16x16 field exactly over one of your textures (or in the upper corner if that matches your grid too) and use the menu "SetSnap". Turn on "Snap" to make the grid active.





To be continued....





Rough Functionality Descriptions





Key and Mouse functions


The keyboard shortcuts for menu options are listed beside the menu function itself. Most use the shift, ctrl or alt key in addition. The left mouse button selects faces/vertexes or menus while the right mouse button can rotate or zoom the 3d object. Press and hold the right mouse button to rotate. Press alt in addition to change the rotational axis, or press shift and alt to zoom the object.





Basic Functions


Load and Save work for our pe format only. In order to load 3DS files use the Import 3DS File option (see restrictions below). The Object Editor saves all information of the edited object into two files: The *.RRF is the object itself with all game information, the *.RRI is a info file which only the object editor needs.


Shading Setup lets you define the way light is reflected from a surface. It uses the same functionality like 3DS or 3DS Max, so artists should be familiar with it. The only restriction is that a shading type is assigned to one palette, and in turn the game only can support a limited number of palettes. What this means is that all textures in the texture library define the total number of palettes. It is the task of the artist to reduce his textures to existing palettes.


The Edit menu offers selection methods. Select vertex and select face work like in 3DS. Just click on any number vertexes or faces and they will become selected. Clicking again will deselect a vertex or face respectively. For faster access deselect (or space key) and select all (Strg-A) is supported as well.


Select Box is to select the bounding boxes of an object. 


The Windows menu lets you change the render mode: normal (textured), wire-frame and bounding box on.


The Assign menu gives you the ability to define and assign materials to faces.








Define Material shows the above dialog. The pop-up menu of the materials lets you choose among your defined set. Color/Texture switches between single color faces and textured faces. These faces can be shaded using the Shading settings. Flat and Phong shading use different algorithms and differ in speed as well. Most (flat) faces should be flat shaded. Phong shading should be reserved for faces which should appear rounded for speed reasons. Note that Phong and Flat shading is limited to textured surfaces (ie. Single color faces can’t be phong or flat shaded <yet>).


The color button lets you pick the single color while the two checkboxes Mask Texture and Two sided define two special faces. Mask Texture will set the color 0 (the background color) to transparent. This mode we call “Sprite” mode because all wheels, infantry men and plants will use this mode. Two sided will set the face so that the backface is visible. This allows complex objects like wheels to be constructed with one face only to save faces. Both of these options can be assigned to a single face to give a sprite two sides (99% of sprites are two sided as well).





The Toolbar


The tool bar gives fast access to defined group selections, materials and attributes. The groups allow to assign faces to selections which can be accessed later (useful for faces with the same textures, attributes etc.). Simply select faces and press the “sum” sign which assigns them to the named group. To select the defined group later use the pop-up window to show the group and press the arrow button (note: this allows a fast modify selection option: press “select group”, add faces, press “assign to group”).


The same applies to material and attributes, only that they will work from assigned materials and attributes respectively. The paint button is a shortcut for assign texture and the two arrows allow to rotate a texture of one or more faces. 





The Texture Library


The right window is the texture library. Here you can import BMP files and cut textures into the library to be assigned to faces. With Load/Save you can save the library. The game supports 8 texture libraries and will pick the paletteo of the last object you pasted. this makes it necessary to use BMP's with different palettes with caution. Use one BMP per library from which you copy from, this prevents errors or messed up libraries.


With load image (or the shortcut icon) you can load a BMP into a window. This window lets you set a predefined square (length/width multiples of 16) on a picture and with cut/paste you can put the texture into the image library window. Paste works from all programs who support BMP.


To select a texture to assign it to one or more faces just click on one and the default size will be set. You can adjust this size (within certain limits) to use only portions of a texture.


The texture libraries for the games are called texture1.tlb through texture8.tlb. Note that you can save them with a different name for variations (winter camouflage).


IMPORTANT: because of a bug in Delphi you MUST paste textures into the library in 24bit mode, ie. set your desktop to 24 bit color. Because the Scenario Editor must use 16bit color unfortunately you have to switch between those two.





3DS Import Guidelines


The following restrictions apply to imported 3DS models.


- object names must be under 11 characters in length


- scale the modell that 1000 units in Max equals 1 meter of your modell


- with 3DS models you have to link all objects together. Use “ResetXForm” to reset transformations on your model


- use rectangles and quads because triangles are not handled well with our renderer


- when importing the objects use “quad optimize” at full level (default setting)


- pivot points for the gun, hatches, MG and turret must be correctly defined


- bounding boxes must be named bboxx, with xx standing for any defition





Known Bugs


- Some faces have wrong normals. The ability to flip normals is implemented with the circle button �








